Tag Archives: Security

Information on Heartbleed

heartbleedYou may have heard the term Heartbleed in the news recently and may be wondering what exactly it is. Basically, Heartbleed is a widespread vulnerability resulting from an error in the OpenSSL toolkit. We became aware this issue when it was announced and within a couple of hours processed the security update for our servers. For those looking for a bit more information on Heartbleed, please visit heartbleed.com.

WordPress 3.7 “Basie”

WORDPRESS_3.7

Hey everyone, we wanted to let you know a new WordPress update is now available for download! Here are some of the features.

  • Updates while you sleep: With WordPress 3.7, you don’t have to lift a finger to apply maintenance and security updates. Most sites are now able to automatically apply these updates in the background. The update process also has been made even more reliable and secure, with dozens of new checks and safeguards.
  • Stronger password recommendations: Your password is your site’s first line of defense. It’s best to create passwords that are complex, long, and unique. To that end, our password meter has been updated in WordPress 3.7 to recognize common mistakes that can weaken your password: dates, names, keyboard patterns (123456789), and even pop culture references.
  • Better global support: Localized versions of WordPress will receive faster and more complete translations. WordPress 3.7 adds support for automatically installing the right language files and keeping them up to date, a boon for the many millions who use WordPress in a language other than English.

Want to add WordPress to your hosting account? Check out TierraNet’s hosting options.